MSD Tech Support Forums

Go Back   MSD Tech Support Forums > MSD Ignition Forums > Trouble-Shooting

Trouble-Shooting Diagnose your ignition

Reply
 
Thread Tools
  #1  
Old 09-08-2003, 05:51 PM
Blue Fastback Blue Fastback is offline
Junior Member
 
Join Date: Sep 2003
Posts: 3
Default

I have had nothing but tach problems after installing my MSD6al. The car is a 73 mustang using a duraspark distributor,MSD6al, 8920 adaptor,factory tach. All worked fine for a year then the tach quit working all together. I replaced the 8920 adaptor and the tach started working but seemed a little off in rpm. Then the tach quit working all together. Had the tach rebuilt and had to eliminate the tach adaptor to make the tach work. This tach is made different then the old tach but still looks original. One of the wires from the tach goes to ground and the other I have hooked to the tach output of the MSD6al unit. My problem now is the tach works just fine until 3000RPM it will not read any higher but the engine is reving higher then 3000. The tach does not bounce at allit just stays steady. I removed the tach and had it rechecked at the rebuilderand it worked just fine on there machine.HELP.(sorry for the long post)
Reply With Quote
  #2  
Old 09-09-2003, 09:53 AM
msdtech2's Avatar
msdtech2 msdtech2 is offline
Senior Member
 
Join Date: Jun 2003
Posts: 680
Default

Normally on the tach output of the MSD Unit is going to work or not. We have had some tachs that will jump around, but the problem would be noise issues causing the erratic readings. The problem that you are describing is that the tach will operate smoothly until it reaches 3000 and will not go any higher. It seems that the tach is not able to read the signal above 3000 RPM's. I would recommend trying a different tach; one that is compatible to the MSD Unit to see how another one operates. Also you may want to ask the rebuilder of the tach, that if it was designed to accept a 12 volt square wave with a 20% duty cycle. This is the spec output of the tach output of the MSD Unit.
Thanks,
msdtech2
Reply With Quote
  #3  
Old 09-09-2003, 06:45 PM
Blue Fastback Blue Fastback is offline
Junior Member
 
Join Date: Sep 2003
Posts: 3
Default

You are correct, the tach works very smooth until 3000 with no erratic readings but just stops at 3000. I will try to borrow a different tach to temporarily mount and see what it does. I sure hope it is not the tach itself that is incompatable with the msd. The tach cost me a lot of money to have repaired and seems very odd it just stops a 3000. I did witness the tach does work just fine on there test machine. Thanks I will let you know what happens.
Reply With Quote
  #4  
Old 09-09-2003, 08:35 PM
msdtech2's Avatar
msdtech2 msdtech2 is offline
Senior Member
 
Join Date: Jun 2003
Posts: 680
Default

Thanks for posting, and let me know.
msdtech2
Reply With Quote
  #5  
Old 09-10-2003, 06:02 PM
Blue Fastback Blue Fastback is offline
Junior Member
 
Join Date: Sep 2003
Posts: 3
Default

I hooked up a different brand tach using the same wires as my old tach and it works just fine.

1. Is my factory/rebuilt tach not compatible with MSD ignition or do I need some type of adaptor to get it to work properly?

2. Do I need to locate another factory tach.

3. I have heard of many people with 71-73 mustangs having problems like the tach quit working after a while like mine did. Are we doing something wrong on installation?

Thanks
Reply With Quote
  #6  
Old 09-11-2003, 11:19 AM
msdtech2's Avatar
msdtech2 msdtech2 is offline
Senior Member
 
Join Date: Jun 2003
Posts: 680
Default

The PN 8920 is the correct adapter, but you will have to contact the rebuilder and see if he could make it compatible, or you may even put the factory Duraspark back on and see if it will work properly. The signal of the MSD unit is not strong enough to damage a tach. It could also be the tachs that are quitting are worn out tachs; after all they are from the 70's.
msdtech2
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Tach Output On 6t Mooreboys Trouble-Shooting 13 07-25-2005 11:39 AM
Tach Woooos!!!! luccamaro68 Trouble-Shooting 4 04-28-2005 10:19 AM
Msd 6al Tach Trigger Output ... Test? Monstermach Trouble-Shooting 7 01-18-2005 02:48 PM
Msd 8572 Mechanical Tach Drive Distributor.... Flared69 Trouble-Shooting 2 12-10-2004 06:06 PM
Factory Tach notach Trouble-Shooting 1 10-15-2004 09:20 AM


All times are GMT -6. The time now is 03:20 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
2011 MSD Performance