MSD Tech Support Forums

Go Back   MSD Tech Support Forums > MSD Ignition Forums > Trouble-Shooting

Trouble-Shooting Diagnose your ignition

Reply
 
Thread Tools
  #1  
Old 08-07-2003, 12:31 AM
79spitfire 79spitfire is offline
Junior Member
 
Join Date: Aug 2003
Posts: 3
Default

I have the 6AL, Blaster2 coil, and 8.5 mm heilicoil plug wires on a Triumph Spitfire using a Toyota driveline. At 3500 rpm (hwy speed of 70) it misfires, or more exactly drops a cylinder. This also shows on the tach as a rpm drop. I have replaced, plugs, wires, cap, rotor, and pickup coil in dist. The system has been working on the car since the begining of the year, and just recently began acting up. I installed a stock Toyota ignitor and coil as a substitute for the MSD and coil and the problem went away. What could be the problem? Cap, rotor, and pickup coil, have been substituted recently to no effect. If the stock pickup coil is not compatable whith the ignition box, Why has it worked untill now, and why at 3500 rpm?

Thank you
79spitfire
Reply With Quote
  #2  
Old 08-07-2003, 06:43 AM
msdtech1's Avatar
msdtech1 msdtech1 is offline
Senior Member
 
Join Date: Apr 2003
Posts: 761
Default

If you are triggering the MSD through the Violet/Green wires then make sure that those two wires are not run near or along side any of the spark plug wires or the coil wire. You may be getting a false trigger through the magnetic pickup input which is causing the miss-fire. Also, make sure the green wire is twisted around the violet wire all the way from the pickup to the MSD box. The green wire acts as a shield for the violet magnetic positive wire. Try moving the wires to see if it makes a difference. Also, try looking for signs of arcing when it is dark. Start the engine and rev it up in the evening without any lights on and look for signs of a spark. If you see any that is a good place to start looking for a problem.

MSD Tech1
Reply With Quote
  #3  
Old 08-10-2003, 12:17 PM
79spitfire 79spitfire is offline
Junior Member
 
Join Date: Aug 2003
Posts: 3
Default

No arcing in the dark at 3500 rpm, Cannot load the engine because it is a stickshift. The pickup wires are at least 3 inches from the plug wires and the power leads to the MSD. It is however close to the alternator, and it is un-avoidable as the alterntator is near the distributor. Is there any way to further shield the pickup wires or should it be trigered through the Toyota ignitor and the white wire? I was hoping for a cleaner installation of the unit.

Thank you
79spitfire
Reply With Quote
  #4  
Old 08-11-2003, 01:57 PM
msdtech2's Avatar
msdtech2 msdtech2 is offline
Senior Member
 
Join Date: Jun 2003
Posts: 680
Default

It sounds like it is picking up noise either through the alternator or through plug wires. There is a way to shield this noise is by using a shielded cable. We offer one that is a part number 8862 Harness, which replace the current cable that you have. The other is to go to local electronic store and purchase a 2 wire shielded cable and you will have to make your own connections. By switching to the igniter, you are this eliminate the mag pick up, so either way it will work.
Thanks,
msdtech2
Reply With Quote
  #5  
Old 08-11-2003, 08:31 PM
79spitfire 79spitfire is offline
Junior Member
 
Join Date: Aug 2003
Posts: 3
Default

Thank you I will try that!
Reply With Quote
  #6  
Old 08-15-2003, 06:38 PM
msdtech1's Avatar
msdtech1 msdtech1 is offline
Senior Member
 
Join Date: Apr 2003
Posts: 761
Default

Let us know if that works or if you need additional help.

MSD Tech1
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
1980 Toyota Land Cruiser Ignition System cobrien Applications 3 11-29-2005 09:37 AM
Questions About Ignition 68coupe Trouble-Shooting 5 08-09-2005 08:26 AM
Ignition And Coilsystem For 4 Stroke Atv strepto Applications 5 02-03-2005 09:51 AM
Marine Ignition start problems diehard_dude Trouble-Shooting 7 08-05-2003 03:28 PM
Ignition components for Nissan Skyline Jenova Applications 4 07-11-2003 08:45 AM


All times are GMT -6. The time now is 09:48 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
©2011 MSD Performance