MSD Tech Support Forums

Go Back   MSD Tech Support Forums > MSD General Discussion Forums > Bench Racing

Bench Racing A place to talk about anything racing, cruising, your car, etc...

Reply
 
Thread Tools
  #1  
Old 08-26-2012, 03:48 PM
chevellessman496 chevellessman496 is offline
Junior Member
 
Join Date: Feb 2010
Posts: 2
Question Crank Trigger Troublshooting

I installed a crank trigger on my 498 BBC. I took the car to the drag strip on two different accessions and had the same issue. I had a misfire at while under load. I thought it was the 1050 dominator carburetor, so my friend let me use his 1150 dominator. Well, it did the same thing. So we disconnected the crank trigger and low and behold the miss went away.
I changed the eye. (this is the second eye). I check the both eyes and I checked the wire from the mad box to the crank trigger and it checks out the same as a new wire does. I do have this one run through the frame and up through the firewall to the msd box.
Help!! Does anyone have any ideas... I want to keep it on the engine because on the engine dyno, it added 25 horsepower just by plugging it in and doing NOTHING else.
Reply With Quote
  #2  
Old 08-27-2012, 07:24 AM
msdtech1955's Avatar
msdtech1955 msdtech1955 is offline
Senior Member
 
Join Date: Jan 2008
Posts: 8,703
Default

did we check rotor phasing ? is the distributor locked out?
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 05:18 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
2011 MSD Performance