MSD Tech Support Forums

Go Back   MSD Tech Support Forums > MSD Ignition Forums > Trouble-Shooting

Trouble-Shooting Diagnose your ignition

Reply
 
Thread Tools
  #1  
Old 02-06-2012, 09:35 PM
jh96ss jh96ss is offline
Junior Member
 
Join Date: Oct 2011
Posts: 3
Default MSD Opti was hungry

My 1996 Impala SS was throwing the high resol code,can't remember the code # and cutting off while driving so I pulled the opti apart and it was doing the same as dookie454's and the rotor was eating the black backing plate. Any advice on how to correct this? only has 30000 mile of daily driving no drag racing or anything of that nature.

Thanks Jeremy
Reply With Quote
  #2  
Old 02-07-2012, 07:01 AM
msdtech1955's Avatar
msdtech1955 msdtech1955 is offline
Senior Member
 
Join Date: Jan 2008
Posts: 9,030
Default

well for starters...in order to help you .....either email us or post pictures so i can see what caused it.
i assume, you have it apart at this time?

are you referring to dan ( dookie 454 -mega squirt guy)
running a pro charger on a camaro.

Last edited by msdtech1955; 02-07-2012 at 07:05 AM.
Reply With Quote
  #3  
Old 02-08-2012, 03:13 PM
jh96ss jh96ss is offline
Junior Member
 
Join Date: Oct 2011
Posts: 3
Default

Okay i'm a member on impala ss fourm since 5/28/06 I dont know dookie454 . If remember correctly there are not clear directions where the o ring goes And why did you post my e-mail address please delete it.
Reply With Quote
  #4  
Old 02-08-2012, 03:24 PM
msdtech1955's Avatar
msdtech1955 msdtech1955 is offline
Senior Member
 
Join Date: Jan 2008
Posts: 9,030
Default

well, if you can get an rma number and send it to us for inspection...
i can tell you what happened .

http://www.msdignition.com/RMA_step0.aspx/

and attention it to msdtech.
Reply With Quote
  #5  
Old 02-08-2012, 03:39 PM
msdtech1955's Avatar
msdtech1955 msdtech1955 is offline
Senior Member
 
Join Date: Jan 2008
Posts: 9,030
Default

here ya go .
lt1seal.jpg

lt-1 web1.JPG

lt-1 web2.JPG

lt-1 web3.JPG
Reply With Quote
  #6  
Old 02-08-2012, 03:47 PM
jh96ss jh96ss is offline
Junior Member
 
Join Date: Oct 2011
Posts: 3
Default

Thanks for the pic thats where i installed the o-ring.This has been on the car for 5 years never had a problem til 3 months ago. I doubt i'm gonna return it not gonna pay for shipping and repairs.
Reply With Quote
  #7  
Old 02-08-2012, 03:48 PM
msdtech1955's Avatar
msdtech1955 msdtech1955 is offline
Senior Member
 
Join Date: Jan 2008
Posts: 9,030
Default

so what is it your exactly asking ?

do you want us to pick it up?

or you have no intensions on fixing this?
Reply With Quote
  #8  
Old 02-08-2012, 10:32 PM
dookie454 dookie454 is offline
Junior Member
 
Join Date: Aug 2011
Posts: 16
Default

Here's original install directions regarding the O-ring. Much different than what MSDTech posted, no reference to anything about twisting, kinking, etc. Though my seal was flat and straight.
Attached Images
File Type: jpg IMG_8800.JPG (2.72 MB, 9 views)
Reply With Quote
  #9  
Old 02-09-2012, 07:50 AM
msdtech1955's Avatar
msdtech1955 msdtech1955 is offline
Senior Member
 
Join Date: Jan 2008
Posts: 9,030
Default

ok, one more time...you dont call or post a picture of your chest complaining of chest pains to a doctor and say fix it !

you two are going to have to send the opti in so we can see it .
look at date codes, test bearing, look and tear down the whole distributor.

so what is it your exactly asking ?

do you want us to pick it up?

or you have no intensions on fixing this
Reply With Quote
  #10  
Old 02-10-2012, 10:01 PM
dookie454 dookie454 is offline
Junior Member
 
Join Date: Aug 2011
Posts: 16
Default

I was just posting my directions since they are not what your directions showed, wanted to make sure we are on same page.

Yes, Im sending mine in, just busy but getting everything together and getting RMA with work and all.

so what is it your exactly asking ? I would hope it's fixed since there are revisions and this is the second MSD that failed (first to the rotor falling off and I didn't even take that one apart during install fearing a rotor failure).

do you want us to pick it up? yes I've put too much time and work into this

or you have no intensions on fixing this: yes, I want it fixed

Last edited by dookie454; 04-27-2012 at 11:53 PM.
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 04:06 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
2011 MSD Performance