MSD Tech Support Forums

Go Back   MSD Tech Support Forums > MSD Ignition Forums > Trouble-Shooting

Trouble-Shooting Diagnose your ignition

Reply
 
Thread Tools
  #1  
Old 04-07-2012, 04:50 PM
Twin_Turbo Twin_Turbo is offline
Junior Member
 
Join Date: Mar 2012
Posts: 4
Default MSD 6 digital issues

Have a prob w/ an MSD 6 Digital. Installed it, worked fine. After a couple of times starting the car it's now dead. The engine is enw, tuning the EFI so it only idled a bit and was running for some short intervals.

The led light does not always come on with the ign. key in the on position. I thought it was an ign. switched 12V problem but it isn't, it's also not a ground prob. The 6 is wired directly to the battery, all wiring is brand new, even the battery cables and all ground cables on the engine, all heavy oversized copper cables. All connections are weatherpack and soldered.

If I unhook the neg. battery cable and then hook it back up and then turn the ign. on the led illuminates. When cranking it flashes but when turning the key off and back on again the led never comes back on unless I remove the neg. cable again. It's like some internal component needs to bleed off (capacitor) or it won't work. With led flashing there is no spark. I have it wired so that I have a "plug" that I can plug in place of the weartherpack to the ignition so that it completely bypasses the msd system (have been stranded before LOL) and bypassing it the car runs just fine.

I'm 99.9999% sure the digital 6 is dead but I am wondering how this is possible.

I live in The Netherlands and this is not the 1st MSD to die on me but it's almost brand new, bought it last year when I was building the car. What am I to do with it? It cost me 300 Euros, almost 450$ back then..a little stuiff for maybe 30 minutes of run time.
Reply With Quote
  #2  
Old 04-10-2012, 09:16 AM
msdtech27's Avatar
msdtech27 msdtech27 is offline
Certified MSD Tech
 
Join Date: Sep 2008
Posts: 626
Default

we do warranty our products for a year from the date of purchase, but since you are in the Neterlands shipping will be a bit expensive. you will need to call us so that you can send the unit in for repair.. :/ 1-888-673-7659
__________________
Reply With Quote
  #3  
Old 04-17-2012, 03:18 PM
Twin_Turbo Twin_Turbo is offline
Junior Member
 
Join Date: Mar 2012
Posts: 4
Default

I will call, no problem.
Reply With Quote
  #4  
Old 04-17-2012, 03:25 PM
Twin_Turbo Twin_Turbo is offline
Junior Member
 
Join Date: Mar 2012
Posts: 4
Default

The number isn't correct, I get a recording babbling about some ami test menu

I bought the box from an official msd dealer in greece called telematica europe

http://www.msdpower.com/index.php

Should I go through them or straight to msd??
Reply With Quote
  #5  
Old 04-19-2012, 01:50 AM
Twin_Turbo Twin_Turbo is offline
Junior Member
 
Join Date: Mar 2012
Posts: 4
Default

bump, need this taken care of asap, want to drive this upcoming season

Last edited by Twin_Turbo; 04-19-2012 at 03:11 AM.
Reply With Quote
  #6  
Old 04-19-2012, 08:50 AM
msdtech1955's Avatar
msdtech1955 msdtech1955 is offline
Senior Member
 
Join Date: Jan 2008
Posts: 8,833
Default

915-857-5200 ext 1162 ( rma department)
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 03:05 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
2011 MSD Performance