MSD Tech Support Forums

MSD Tech Support Forums (
-   Installation Questions (
-   -   What is the difficulty of installing an Optispark (

tsamford 10-03-2012 10:28 AM

What is the difficulty of installing an Optispark
I see where the difficulty of installing an Optispark on an LT1 has been questioned. Here are a few photos showing the steps for installation:

Here is an image of a 92 LT1. The antifreeze, air cleaner system, water hoses and drive belt are already removed.

Here is the water pump. If you peer down this hole, you can see the Optispark and connector beneath the water pump.

Six bolts and the water pump comes off. Dude.. It is filthy back here.. Unfortunately, due to the Optisparks location, washing the engine is a bad idea.
Now you can see the factory Optispark. It sits behind the harmonic dampener.

tsamford 10-03-2012 10:29 AM

On my 92 Corvette, the steering components are in the way. So I pull the lines and pull them out of the way with a small rope. Remove three bolts and using a 6 inch two arm puller, I ease the harmonic dampener off.

Here is the full view of the factory Optispark. Three bolts and it off it comes.

Here is an image of the MSD 8381 Optispark installed. Looks pretty clean, right? I replaced the water pump drive seal and the Optispark drive seal prior to installation.

tsamford 10-03-2012 10:30 AM

Installed 8381 prior to putting it all back together. Sure is pretty..

msdtech1955 10-03-2012 10:48 AM

4 Attachment(s)
heres my install
Attachment 2461

Attachment 2462

Attachment 2463

Attachment 2464

msdtech1955 10-03-2012 10:50 AM

4 Attachment(s)
some more...
Attachment 2465

Attachment 2466

Attachment 2467

Attachment 2468

msdtech1955 10-03-2012 10:51 AM

1 Attachment(s)
had it apart and back together in 4 hours...
the camaro and firebird would do underneath ( no need to remove radiator)
and the impalas( caprice..was even easier )

Attachment 2469

msdtech1955 10-03-2012 10:54 AM

1 Attachment(s)
shot of vacuum tee
Attachment 2470

tsamford 10-03-2012 11:09 AM

I finished the install last night. It runs better than it ever has. Very smooth. And looks great too. It totally solved the issues I was having with the engine not wanting to run after it was hot. The old Optispark was not throwing any codes. :thumbup1:

tsamford 10-03-2012 11:31 AM

I did this as well.

All times are GMT -6. The time now is 01:01 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
2015 MSD Performance