MSD Tech Support Forums

MSD Tech Support Forums (http://www.msdignition.com/forum/index.php)
-   Trouble-Shooting (http://www.msdignition.com/forum/forumdisplay.php?f=8)
-   -   6m2 (http://www.msdignition.com/forum/showthread.php?t=18448)

squezen 09-10-2012 11:34 AM

6m2
 
What is up with the marine ignition box ? I've had to replace it 3 times in the past 6 years. I've talked to a couple other boat owners that have had the same issues. It starts and runs perfect one day, no spark the next.
Fortunitly it has never left us stranded, but that day may come. With this unit being epoxy filled, it can't be repaired. That means having to purchase another one and at over $300. I hate to say it, but I'm seriously considering another brand.
Has anyone else had this problem, if so, what did you do ?

msdtech1955 09-10-2012 11:45 AM

are you asking for help? or venting ?

squezen 09-10-2012 11:56 AM

6m2
 
I like the MSD, I just wish it would last longer than a couple seasons. Help would be greatly appreciated.

msdtech1955 09-11-2012 09:29 AM

p/m daytime phone number

McGyver 09-18-2012 10:46 AM

Quote:

Originally Posted by squezen (Post 76665)
What is up with the marine ignition box ? I've had to replace it 3 times in the past 6 years. I've talked to a couple other boat owners that have had the same issues. It starts and runs perfect one day, no spark the next.
Fortunitly it has never left us stranded, but that day may come. With this unit being epoxy filled, it can't be repaired. That means having to purchase another one and at over $300. I hate to say it, but I'm seriously considering another brand.
Has anyone else had this problem, if so, what did you do ?

Yes, I have had the same problem and am now on my 4th marine box. It happens the same way, runs fine all day - put it on the trailer - no spark the next time. I haven't been stranded yet but I am just waiting. At first the constant hot came off the starter. One box lasted 6 years. The next one only 2 years. I changed it up and wired it direct to the battery but that one only lasted 3 years. I have a 27' Warlock World Class with a 510" normally aspirated motor that gets maybe 20 hours per year of use. I always take spare parts but I should not have to take a whole ignition system.

squezen 09-18-2012 09:57 PM

6m2
 
That's unfortunate, but it does make me feel a little better knowing its not just me. Don't know what to do to remedy the issue. MSD did send me a capacitor to install in the wires going to the battery, I'll give it a shot, certainly can't hurt. I have a similar setup as yours, Rayson Craft 26' cat, 540ci, Whipple Charger. All MSD ignition components, so compatibility shouldn't be the issue. Installing the new 6M2L, maybe I'll have better luck. Thanks for the input.

mafman 09-26-2012 04:59 PM

I have a 6M-2 sitting on the floor, next to my bed. It seems to be working better there, keeping the carpet held down, than it does in my boat. I bought it in May of 2010 when my MSD 6AL box failed (it was Memorial Day weekend 2010, Saturday afternoon. Luckily, Honker Cut Marine was open late). Since then I've used it no more than 10 hours. It was working a month ago, toward the middle of August, when I dropped the rebuilt 454 back into the boat. Tested the motor for about 30 minutes, set the idle, set the timing, and then towed the boat 325 miles, from Los Angeles to the Bay Area. It hasn't started since. Trouble shot the wiring last night, and concluded the problem was with the 6M-2. Batteries are charged at 12.5v. Have 12.5v at both red wires. Good ground. Good MSD coil. No spark. I'm not surprised after all the reviews of MSD I've read on-line. I'll re-install my repaired 6AL box, and buy Mallory, Crane, or maybe even Summit, as a spare, and wait for the MSD 6AL to fail again. $360 for 10 hours of use? Seriously?

msdtech1955 09-27-2012 08:36 AM

so are you asking or venting ?

mafman 09-27-2012 01:39 PM

Asking? Would you refund my $360? I'll send you the receipt. Will you replace my 6M-2 box? It's filled with epoxy and can't be repaired. There's not much I can do, except buy another box. MSD only warranties their products for a year.

Venting? The MSD brand, based upon my experience with a 6AL box and a 6M-2 box, is unreliable. There's my vent. Besides, this is the purpose of these forums... to ask questions, exchange experiences, and vent if necessary. That's how I wound up here in the first place. Looking for answers to why my 6M-2 box won't light my engine. And now I know I'm not the only one.

The last thing I want is another ignition box in my boat, MSD or otherwise, that won't start my motor, while I'm floating on the San Joaquin river with a 5 mph outgoing current sucking me toward the Golden Gate bridge.

mafman 10-10-2012 02:19 AM

Last weekend I installed my old (repaired in 2010) 6AL box and the motor fired right up. That was the first time re-installing and using the repaired 6AL box since it stopped working Memorial Day weekend, 2010. At least I know the repair was done correctly by MSD. Tonight I started the motor and warmed it up. I put the 6M-2 box back in and nothing. So at this point I'm 100% certain the 6M-2 box failed. I originally came to this forum looking for answers to my problem with the 6M-2 box. I'm not here to bag on MSD (I have a 6AL box, a 6M-2 box, an MSD high vibration coil, and an MSD billet distributor), but if you have 24,153 views on your "Return / Repair Notice" forum, you might have a problem with your product line. Let the numbers speak for themselves. That's not a very comfortable situation for a boat owner...

At this point I'm looking at the $134 Summit 850610 box, or the Mallory Hyfire 6, as a spare. From a financial perspective I can buy three Summit boxes for the price of the 6M-2 box. I'll run the MSD 6AL box until the next failure, and go from there.


All times are GMT -6. The time now is 04:50 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
2011 MSD Performance