PDA

View Full Version : MSD 6A


87stang2002M3
06-20-2003, 05:32 PM
I recently installed an MSD 6A box in my 87 mustang with speed density not mass air, i used the TFI harness connector that MSD recomends. My problem is that the MSD box is burning out the fuel pump circuit in my computer. The car ran fine for about a month, then the fuel pump wouldn't shut off. I tested a bunch of stuff on the car and found the computer to be bad. I replaced the computer and and now another month later the exact same thing happened. I had to disconnect the MSD box seeing as how i don't like buying computers for my car. I'm wondering if this is being caused by the speed density instead of mass air or if it's a problem somewhere else. Any help would be appreciated.
jeff

msdtech1
06-25-2003, 09:54 AM
I have traced back all the connections that you would have made involving the MSD 6A on your 1987 Ford Mustang. The MSD Red (18 ga.) wire is run through your mustangs EEC Power Relay and therefore your computer would be protected at that point. The MSD White (18 ga.) wire is an input wire and your Mustangs distributor module delivers the trigger signal to it. That wire, color coded DK-GRN-YEL also feeds back and is connected to the computer at pin 4. The MSD White wire is not a driver wire and therefore cannot affect the computer. I do not believe it is the MSD causing the failed computer modules on your mustang. As a test, I would suggest leaving the MSD Disconnected for a while and see if the problem still occurs. Please let us know what you find.

MSD Tech1