PDA

View Full Version : Tach Problems & Other Things


shibbyme
09-21-2003, 12:27 PM
I installed a MSD 6AL ignition controller, MSD 8350 distributor with an Pro Blaster 2 coil and superconductor plug wires on my 1972 Mach 1. It has a 351C engine with a Holley 770 CFM carb. Compression is 9.8:1, fuel mixture is rich, fuel octane is 93, load is medium. I put in 1 heavy and 1 light spring with the silver bushing in the distributor.

First, do the springs and bushing seem right for this application?

Next, the tach barely registers now. It seems to read anly about 10% - 20% of what it should. The tach was fed from the ignition key and (+) on the coil.

Do I need to run a wire from the 6AL to the (+) wire or do I need a MSD-8910 tach adapter?

Thank you.

msdtech1
09-21-2003, 04:01 PM
The spring and bushing combination that you are running will bring the total timing in at 4000 rpm. If you plan on staying with the Silver bushing then I would try running the two Blue springs. It will bring the total advance in by 3500 rpm and will probally help the throttle responce a little. To cure your tach issue, you will need to run the MSD PN 8920 Tach Adpater.

MSD Tech1

shibbyme
09-22-2003, 03:47 PM
I tried the two blue springs and the engine ran a little rough so I switched to light silver and heavy silver.

Would you recommend changing the bushing? If so, which one?

Thanks

msdtech1
09-22-2003, 10:06 PM
The bushing that you are running is fine, Apparently your engine likes a little less aggressive advance curve.

MSD Tech1