PDA

View Full Version : MSD-10+ sent for repair


Wildcatracing
01-15-2012, 01:08 PM
Hi guys, is there any way I can get an update on this unit that was delivered to you on 3 Jan 2012? It was from Graham Carter but did not have an RMA number with it. Your help would be appreciated, thanks Graham

msdtech1955
01-16-2012, 08:27 AM
p/m your address again

Wildcatracing
01-17-2012, 02:48 PM
I have sent my details to you via PM, please let me know if you dont receive it, I can also be contacted on wildcatracing@gmail.com. Cheers Graham

msdtech1955
01-17-2012, 03:22 PM
rma 84330

the power board circuit was burnt, looks like you worked on it..
it's the out put circuit to the coil .....

by chance , did you feed 12volts to that coil ( blue or red )?


it is done .

Wildcatracing
01-17-2012, 07:03 PM
no, I did not put 12v to the coil , when the unit failed we tried another coil with no luck, swapped the box with my only spare and away it went. I removed the burnt components and cleaned up the circuit board in that area with meths. As I could not identify the burnt components I sent it to you. Cheers Graham

Wildcatracing
01-18-2012, 12:25 PM
Hi MSDtech1955,

re your comment "it is done", does that mean it has been repaired or it is dead??

msdtech1955
01-18-2012, 12:38 PM
it's repaired and on the way back

Wildcatracing
01-18-2012, 12:59 PM
:thumbup1:you guys are fantastic and a credit to the sport !! My sincere thanks for sorting this out as I firmly believe the MSD-10+ is the best ignition ever built ! Cheers Graham